Results 1 to 10 of 10

Thread: How to disable Supermicro X10 mobo beep codes for no keyboard

  1. #1
    Ambassador from TSBT scole of TSBT's Avatar
    Join Date
    May 8th, 2015
    Location
    Goldsboro, NC
    Posts
    638

    How to disable Supermicro X10 mobo beep codes for no keyboard

    I have a system with a Supermicro X10 mobo and it runs headless; no monitor, keyboard or mouse. When it boots without a keyboard it beeps loudly several times. Anyone know what/if BIOS settings can be changed to disable that warning/error (just that warning, not all)?

  2. #2
    Administrator
    Bryan's Avatar
    Join Date
    October 27th, 2010
    Location
    CO summer, TX winter
    Posts
    5,128

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    I didn't find anything in the manual other than the code it will beep. You might call their customer support and see if they have an answer.

    There is one thing in the boot menu called "quiet boot" but I don't know if that affects beeps or just the logo screen at boot.


  3. #3
    Past Administrator
    Fire$torm's Avatar
    Join Date
    October 13th, 2010
    Location
    In the Big City
    Posts
    7,902

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    First Question: Which X10 MB? ---> SuperMicro X10 (List)

    Just a thought: In the BIOS, usually under "General" settings/tab, there is a setting called "Halt On" where you can select which boot up error the system will stop on. One option should be "All but Keyboard". Have you tried setting it to None?


    Future Maker? Teensy 3.6

  4. #4
    Ambassador from TSBT scole of TSBT's Avatar
    Join Date
    May 8th, 2015
    Location
    Goldsboro, NC
    Posts
    638

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    It's a SuperMicro X10DAi. Its reporting the POST error of 5 beeps which is No Con-In or no Con-Out devices. "Quiet boot" is already enabled. I can't find any other option to control the POST errors. There appears to be an updated BIOS flash but it's not important enough to go there.

  5. #5
    Past Administrator
    Fire$torm's Avatar
    Join Date
    October 13th, 2010
    Location
    In the Big City
    Posts
    7,902

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    Quote Originally Posted by scole of TSBT View Post
    It's a SuperMicro X10DAi. Its reporting the POST error of 5 beeps which is No Con-In or no Con-Out devices. "Quiet boot" is already enabled. I can't find any other option to control the POST errors. There appears to be an updated BIOS flash but it's not important enough to go there.
    After digging through the user manual and the Net, it looks like SuperMiro just expects this board to have a KB and mouse attached.... sigh. This is assuming the beep code error is not related to "PCI or Serial Console Redirection".

    Other than connecting a mouse and KB, the only other option I can think of is to use a dongle like those used with Logitech wireless keyboards/mice (Picture). You, a family member or friend might have one laying around? If not, you can find the cheapest Logitech combo, the MK235, for around $18 on Amazon (List Here). And, having a wireless KB on hand might not be a bad idea.


    Future Maker? Teensy 3.6

  6. #6
    Diamond Member
    zombie67's Avatar
    Join Date
    October 24th, 2010
    Location
    Dublin, CA
    Posts
    5,761

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    I also have at least one machine that requires a keyboard at boot. What a PITA, especially after a power out and I don't have one plugged in, so it won't auto-reboot. The most maddening part is that these are SERVER mobos. Most servers are run headless!
    A state where police work is easy, is also known as a police state.


    Avatar source
    Twitter: @zombie_67



  7. #7
    Ambassador from TSBT scole of TSBT's Avatar
    Join Date
    May 8th, 2015
    Location
    Goldsboro, NC
    Posts
    638

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    It will still boot. The only issue is it runs in a spare office at work and the 5 beeps are a little loud. I don't reboot it often but every time I do, I always hear somebody in the hallway ask what was beeping.
    Last edited by scole of TSBT; 03-15-17 at 10:56 AM.

  8. #8
    Past Administrator
    Fire$torm's Avatar
    Join Date
    October 13th, 2010
    Location
    In the Big City
    Posts
    7,902

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    Oh I forgot to mention that you can always put some duct tape over the hole in the piezo buzzer/speaker.


    Future Maker? Teensy 3.6

  9. #9
    Platinum Member
    Mumps's Avatar
    Join Date
    October 28th, 2010
    Location
    Milwaukee, WI
    Posts
    3,259

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    But he mentioned he didn't want to disable *all* the beepcodes. Just the missing Keyboard/Mouse one.

  10. #10
    Past Administrator
    Fire$torm's Avatar
    Join Date
    October 13th, 2010
    Location
    In the Big City
    Posts
    7,902

    Re: How to disable Supermicro X10 mobo beep codes for no keyboard

    Quote Originally Posted by Mumps View Post
    But he mentioned he didn't want to disable *all* the beepcodes. Just the missing Keyboard/Mouse one.
    The duct tape won't eliminate the beeps, just muffle them so they are not blasting the whole office.


    Future Maker? Teensy 3.6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •