Results 1 to 5 of 5

Thread: GPU missing

  1. #1
    Gold Member
    c303a's Avatar
    Join Date
    October 25th, 2010
    Location
    East Troy, Wi
    Posts
    1,333

    GPU missing

    I have been running GPU Grid with no trouble. I decided I would like to run Poem on the GPU but I get a GPU missing notice. What do I have to do to run it on my 2 GTX 960s. I have the latest Nvidia drivers installed.

    RETIRED. NO JOB. NO MONEY. NO WORRIES!

    Crunched SETI Classic to the end.


    SETI@home classic workunits
    17,550
    SETI@home classic CPU time 86,861 hours




  2. #2
    Diamond Member
    zombie67's Avatar
    Join Date
    October 24th, 2010
    Location
    Dublin, CA
    Posts
    5,761

    Re: GPU missing

    Are you sure BOINC still sees your GPUs? It sees them when starting, in the event log?
    A state where police work is easy, is also known as a police state.


    Avatar source
    Twitter: @zombie_67



  3. #3
    Platinum Member
    Mumps's Avatar
    Join Date
    October 28th, 2010
    Location
    Milwaukee, WI
    Posts
    3,259

    Re: GPU missing

    IIRC, the Poem app is OpenCL only, so that may explain why it's seen on GPU Grid (Cuda) Your BOINC client needs to see the GPU using *both* languages. Below is one of my hosts with just a single GTX 670 in it. Notice BOINC shows it twice. It needs to see the GPU using "Cuda" for GPU Grid, and using "OpenCL" for Poem.

    17-Jan-2016 18:45:52 [---] CUDA: NVIDIA GPU 0: GeForce GTX 670 (driver version 331.11, CUDA version 6.0, compute capability 3.0, 2048MB, 2006MB available, 2915 GFLOPS peak)
    17-Jan-2016 18:45:52 [---] OpenCL: NVIDIA GPU 0: GeForce GTX 670 (driver version 331.113, device version OpenCL 1.1 CUDA, 2048MB, 2006MB available, 2915 GFLOPS peak)

  4. #4
    Gold Member
    c303a's Avatar
    Join Date
    October 25th, 2010
    Location
    East Troy, Wi
    Posts
    1,333

    Re: GPU missing

    2/29/2016 9:12:19 AM | | Starting BOINC client version 7.6.22 for windows_x86_64
    2/29/2016 9:12:19 AM | | log flags: file_xfer, sched_ops, task
    2/29/2016 9:12:19 AM | | Libraries: libcurl/7.45.0 OpenSSL/1.0.2d zlib/1.2.8
    2/29/2016 9:12:19 AM | | Data directory: E:\ProgramData\BOINC
    2/29/2016 9:12:19 AM | | Running under account c303a
    2/29/2016 9:12:20 AM | | CUDA: NVIDIA GPU 0: GeForce GTX 960 (driver version 361.91, CUDA version 8.0, compute capability 5.2, 2048MB, 1636MB available, 2748 GFLOPS peak)
    2/29/2016 9:12:20 AM | | CUDA: NVIDIA GPU 1: GeForce GTX 960 (driver version 361.91, CUDA version 8.0, compute capability 5.2, 2048MB, 1636MB available, 2748 GFLOPS peak)
    2/29/2016 9:12:21 AM | | App version needs OpenCL but GPU doesn't support it
    2/29/2016 9:12:21 AM | Poem@Home | Application uses missing NVIDIA GPU
    2/29/2016 9:12:21 AM | Poem@Home | Missing coprocessor for task poempp_2k39_1456017676_300425179_2
    2/29/2016 9:12:21 AM | Poem@Home | Missing coprocessor for task poempp_2k39_1456215728_1168591517_0
    2/29/2016 9:12:21 AM | Poem@Home | Missing coprocessor for task poempp_2f21_1456215739_681165306_0

    Here is what I am getting when Boinc starts. It is not seeing the opencl. Is there something I hav e to download and install?

    RETIRED. NO JOB. NO MONEY. NO WORRIES!

    Crunched SETI Classic to the end.


    SETI@home classic workunits
    17,550
    SETI@home classic CPU time 86,861 hours




  5. #5
    Gold Member
    c303a's Avatar
    Join Date
    October 25th, 2010
    Location
    East Troy, Wi
    Posts
    1,333

    Re: GPU missing

    Got it. Did a complete uninstall of Nvidia driver then did a clean install of the latest driver. All is well now. Thanks Mumps.

    RETIRED. NO JOB. NO MONEY. NO WORRIES!

    Crunched SETI Classic to the end.


    SETI@home classic workunits
    17,550
    SETI@home classic CPU time 86,861 hours




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •